Initiation au Spanning Tree Protocol

Sommaire

  1. Présentation.
  2. Étape 1 : Câblage du réseau.
  3. Étape 2 : Configuration des commutateurs.
  4. Étape 3 : Configuration des hôtes.
  5. Étape 4 : Examen des données de l’interface VLAN 1.
  6. Étape 5 : Définition des rôles des ports du Spanning Tree sur chaque commutateur.
  7. Étape 6 : Modification de la topologie du réseau.
  8. Étape 7 : Examen du Spanning Tree de chaque commutateur.
  9. Étape 8 : Remarques générales.
  10. Étape 9 : Modification volontaire du pont racine.
  11. Annexe : Running-config.
  12.      Commutateur A.
  13.      Commutateur B.

 

 

Présentation

Spanning Tree Protocol (STP) est un protocole de couche 2 présent sur les ponts et les switchs.

La norme d’STP est la norme IEEE 802.1D. Le but principal d’STP est de s’assurer que nous n’avons pas créé de boucle dans notre réseau quand nous avons des liens redondants, ceux-ci pouvant entraîner des broadcast storms en l’absence d’un traitement de ces liens par STP.

 

Plan réseau

Voici le plan réseau comportant les différents switchs utilisés pour cette initiation ainsi que les deux PC hôtes qui nous serviront à démontrer certains cas d’utilisation du SPT.

Légende
Etat connecté
Etat bloqué
Câble droit
Câble croisé

 

Connectique

Les switchs sont connectés entre eux par un câble croisé et dispose également d’une liaison redondante.

Les deux PC sont reliés par un câble droit à un des deux switchs.

 

Ressources nécessaires

  • Deux commutateurs Cisco 2960 ou autres commutateurs comparables
  • Deux PC Windows, dont un équipé d’un programme d’émulation de terminal ; le premier utilisé en tant qu’hôte, le second en tant que serveur
  • Au moins un câble console, avec connecteur RJ-45 vers DB-9, pour la configuration des commutateurs
  • 2 câbles droits Ethernet
  • 2 câbles de croisement Ethernet
  • Accès à l’invite de commande du PC
  • Accès à la configuration TCP/IP de réseau du PC

 

 

 

Étape 1 : Câblage du réseau

a. À l’aide d’un câble droit Ethernet, connectez l’Hôte 1 au port Fast Ethernet Fa0/7 du Commutateur 1.

b. À l’aide d’un câble droit Ethernet, connectez l’Hôte 2 au port Fast Ethernet Fa0/8 du Commutateur 2.

c. À l’aide d’un câble droit Ethernet, connectez le port Fast Ethernet Fa0/1 du Commutateur 1 au port Fast Ethernet Fa0/1 du Commutateur 2.

d. À l’aide d’un câble droit Ethernet, créez une liaison redondante entre les commutateurs en connectant le port Fast Ethernet Fa0/4 du Commutateur 1 au port Fast Ethernet Fa0/4 du Commutateur2.

 

Quel est l’avantage des liaisons redondantes dans un réseau comme celui-ci ?

Les liaisons redondantes dans un tel réseau permette une tolérance aux pannes. Si la première liaison qui relie les deux switchs venait à être coupée, la deuxième liaison le reliant permettrait d’éviter toute interruption de service.

 

 

 

Étape 2 : Configuration des commutateurs

a. Établissez une session d’émulation de terminal du Commutateur 1 à partir de l’Hôte 1.

Nous nous servons d’un câble console avec connecteur RJ-45 vers DB9 pour relier notre machine hôte 1 au premier commutateur

 

b. Configurez le nom d’hôte du commutateur, les mots de passe, l’adresse IP de l’interface VLAN 1 et le masque de sous-réseau sur le Commutateur 1

Notre configuration de switch étant celle par défaut, nous commençons par lui donner un nom pour pouvoir l’identifier facilement CommA :

Switch>enableSwitch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname CommA
CommA(config)#

Nous pouvons maintenant sécuriser notre switch.

Tout d’abord nous allons veiller à ce que le service de password-encryption soit bien activé pour que les mots de passe n’apparaissent pas en clair dans les fichiers de configuration.

Puis, nous spécifions un mot de passe pour passer en mode privilégié sur le switch une fois connecté (class) ainsi qu’un mot de passe pour pouvoir se connecter en console (CON) ou en ligne virtuelle (VTY) :

CommA(config)#service password-encryptionCommA(config)#enable secret class
CommA(config)#line con 0
CommA(config-line)#password cisco
CommA(config-line)#login
CommA(config-line)#exit
CommA(config)#line vty 0 15
CommA(config-line)#password cisco
CommA(config-line)#login
CommA(config-line)#end
CommA#
%SYS-5-CONFIG_I: Configured from console by console
CommA#

 

Voici le résultat obtenu après avoir nommé le switch et l’avoir sécurisé :

 

Le VLAN 1 étant un vlan créé par défaut, nous n’avons qu’à configurer notre interface :

CommA(config)#interface vlan 1CommA(config-if)#ip address 192.168.1.2 255.255.255.0
CommA(config-if)#no shutdown
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
CommA(config-if)#end

Notre interface est maintenant configurée. Le switch répondra sur le VLAN 1 par l’adresse 192.168.1.2/24.

 

c. Enregistrez la configuration.

Nous enregistrons la configuration en faisant un write :

CommA#writeBuilding configuration…
[OK]
CommA#

A noter que nous pouvons tout classiquement utiliser la commande suivante avec les mêmes effets :

CommA#copy running-config startup-configDestination filename [startup-config]?
Building configuration…
[OK]
CommA#

 

d. Établissez une session d’émulation de terminal du Commutateur 2 à partir de l’Hôte 1 ou de l’Hôte 2.

Nous nous servons d’un câble console avec connecteur RJ-45 vers DB9 pour relier notre machine hôte 2 au deuxième commutateur.

e. Configurez le nom d’hôte du commutateur, les mots de passe, l’adresse IP de l’interface VLAN 1 et le masque de sous-réseau sur le Commutateur 2

Nous configurons ce coup-ci, en une seule fois, le nom du switch CommB, et les passwords pour se connecter en console et en ligne virtuelle puis, au mode privilégié :

Switch>enableSwitch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname CommB
CommB(config)#service password-encryption
CommB(config)#enable secret class
CommB(config)#line con 0
CommB(config-line)#password cisco
CommB(config-line)#login
CommB(config-line)#exit
CommB(config)#line vty 0 15
CommB(config-line)#password cisco
CommB(config-line)#login
CommB(config-line)#end
CommB#
%SYS-5-CONFIG_I: Configured from console by console
CommB#

 

Il reste maintenant à configurer l’interface VLAN1 de ce deuxième commutateur :

CommB#configure terminalEnter configuration commands, one per line.  End with CNTL/Z.
CommB(config)#interface vlan 1
CommB(config-if)#ip address 192.168.1.3 255.255.255.0
CommB(config-if)#no shutdown
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
CommB(config-if)#end
CommB#

Notre interface est maintenant configurée. Le switch répondra sur le VLAN 1 par l’adresse 192.168.1.3/24.

 

f. Enregistrez la configuration.

Nous faisons également un write sur ce commutateur pour enregistrer la configuration :

CommB#writeBuilding configuration…
[OK]
CommB#

Nos deux switchs sont maintenant configurés.

 

 

Étape 3 : Configuration des hôtes

a. Configurez l’hôte1 pour l’utilisation d’une adresse IP sur le même réseau que les commutateurs.

Nous changeons juste l’adresse IP de l’hôte ainsi que son masque de sous réseau 192.168.1.20/24 :

Voici maintenant le résultat d’un ipconfig et d’un ping sur le switch auquel l’hôte est directement connecté :

b. Configurez l’hôte2 pour l’utilisation du même masque de sous-réseau que les commutateurs.

De même sur l’hôte 2, nous configurons l’adresse IP 192.168.1.30/24 :

Et maintenant, le résultat d’un ipconfig et d’un ping sur le switch auquel l’hôte est directement connecté :

Pour vérifier si le réseau est correctement configuré, envoyez une requête ping au serveur, de l’Hôte 1 vers l’Hôte 2.

Sur l’hôte 1, nous effectuons un ping de l’hôte 2 :

La requête ping a-t-elle abouti ?

Le ping a correctement abouti.

c. Si le résultat n’est pas correct, vérifiez à nouveau les connexions et les configurations. Vérifiez si les câbles ne sont pas défectueux et si les connexions sont stables.

 

Étape 4 : Examen des données de l’interface VLAN 1

a. Sur le Commutateur A, tapez la commande show interface vlan1 à l’invite du mode d’exécution privilégié.

CommA#show interface vlan 1
Vlan1 is up, line protocol is up
Hardware is CPU Interface, address is 0009.7c97.41d7 (bia 0009.7c97.41d7)
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 21:40:21, output never, output hang never
Last clearing of « show interface » counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1682 packets input, 530955 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
563859 packets output, 0 bytes, 0 underruns
0 output errors, 23 interface resets
0 output buffer failures, 0 output buffers swapped out
CommA#

 

Quelle est l’adresse MAC du Commutateur A ?

L’adresse MAC du Commutateur A est : 0009.7c97.41d7

b. Sur le Commutateur B, tapez la commande show interface vlan1 à l’invite du mode d’exécution privilégié.

CommB#show interface vlan1
Vlan1 is up, line protocol is up
Hardware is CPU Interface, address is 000b.beab.ee7d (bia 000b.beab.ee7d)
Internet address is 192.168.1.3/24
MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 21:40:21, output never, output hang never
Last clearing of « show interface » counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1682 packets input, 530955 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
563859 packets output, 0 bytes, 0 underruns
0 output errors, 23 interface resets
0 output buffer failures, 0 output buffers swapped out
CommB#

 

Quelle est l’adresse MAC du Commutateur B ?

L’adresse MAC du commutateur B est : 000b.beab.ee7d

 

Quel est le commutateur qui doit être utilisé en tant que racine du Spanning Tree de ce réseau ?

Le commutateur qui doit être utilisé en tant que racine du Spanning Tree sur ce réseau est celui qui a la priorité de pont la plus faible (par défaut en sortie d’usine : 32769).

Comme nous n’avons pour l’instant pas configurer cette priorité, les deux switchs ont une priorité par défaut similaire.

De ce fait, celui qui sera choisi comme pont racine du Spanning Tree sera celui avec la MAC address la plus faible.

CommA : 0009.7c97.41d7
CommB : 000b.beab.ee7d

Le pont racine dans ce réseau sera ainsi le switch CommA.

 

 

Étape 5 : Définition des rôles des ports du Spanning Tree sur chaque commutateur

a. Sur le Commutateur A, tapez la commande show spanning-tree à l’invite du mode d’exécution privilégié.

CommA#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    32769
Address     0009.7C97.41D7
This bridge is the root
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 secBridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     0009.7C97.41D7
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/7            Desg FWD 19        128.7    P2p
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/4            Desg FWD 19        128.4    P2p

CommA#

 

b. Sur le Commutateur B, tapez la commande show spanning-tree à l’invite du mode d’exécution privilégié.

CommB#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    32769
Address     0009.7C97.41D7
Cost        19
Port        1(FastEthernet0/1)
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 secBridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     000B.BEAB.EE7D
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/1            Root FWD 19        128.1    P2p
Fa0/4            Altn BLK 19        128.4    P2p
Fa0/8            Desg FWD 19        128.8    P2p

CommB#

 

Quel commutateur constitue le pont racine ?

Le commutateur faisant office de pont racine est bien le commutateur CommA.

 

c. Le Spanning Tree utilise trois ports sur chaque commutateur. Complétez ce diagramme en indiquant l’état du port et le rôle de chaque port.

Commutateur A :
Interface : Fa 0/7        Rôle : Designated    État : FORWARD
Interface : Fa 0/1        Rôle : Designated    État : FORWARD
Interface : Fa 0/4        Rôle : Designated    État : FORWARD

Commutateur B :
Interface : Fa 0/1        Rôle : Root        État : FORWARD
Interface : Fa 0/4        Rôle : Alternative    État : BLOCKED
Interface : Fa 0/8        Rôle : Designated    État : FORWARD

 

 

Étape 6 : Modification de la topologie du réseau

a. Retirez le câble de croisement du port de transmission sur le pont non-racine.

b. Attendez quelques secondes, puis tapez à nouveau la commande show spanning-tree dans le pont non-racine.

Quelles modifications remarquez-vous dans le Spanning Tree ?

Les lignes d’informations suivantes sont apparues sur le switch.

CommB#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to downCommB#

 

Voici maintenant le résultat de la commande show spanning-tree sur CommB :

CommB#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    32769
Address     0009.7C97.41D7
Cost        19
Port        4(FastEthernet0/4)
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 secBridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     000B.BEAB.EE7D
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/4            Root FWD 19        128.4    P2p
Fa0/8            Desg FWD 19        128.8    P2p

CommB#

Nous pouvons fois qu’il n’y a plus la présence de l’interface FA 0/1, rôle ROOT, en état FORWARD.

Aussi, l’interface Fa0/4 est passé en root et FORWARD en lieu et place d’un état auparavant en BLOCKED dans un rôle Alternatif.

 

c. Examinez le Spanning Tree sur le pont racine.

Quels changements remarquez-vous ?

CommA

CommA#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to down%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to downCommA#

Le commutateur pont racine a vu son interface Fa0/1 disparaître en toute logique.

CommA#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    32769
Address     0009.7C97.41D7
This bridge is the root
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 secBridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     0009.7C97.41D7
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/7            Desg FWD 19        128.7    P2p
Fa0/4            Desg FWD 19        128.4    P2p

CommA#

 

d. Poursuivez l’examen du Spanning Tree sur les deux commutateurs jusqu’au calcul d’une nouvelle arborescence et jusqu’à la transmission ou le blocage de tous les ports. Quelle est la durée de ces opérations ?

En à peine 10 secondes maximum, le calcul d’une nouvelle arborescence est effectuée.

Voici un état d’un ping en continu effectué par l’hôte 1 sur l’hôte 2 :

 

e. Replacez le câble qui a été retiré à l’étape 6a.

f. Attendez que les deux commutateurs terminent le calcul de leurs tables.

Quelles sont les conséquences de ces opérations sur le temps de fonctionnement du réseau ?

Le réseau a eu une coupure de quelques secondes avant que la nouvelle arborescence ne soit définie. En effet, chaque switch renvoit des BPDU pour mettre à jour la nouvelle topologie du réseau.

Résultat d’un ping effectué de l’hôte1 vers l’hôte2 :

 

 

Étape 7 : Examen du Spanning Tree de chaque commutateur

a. Sur chaque commutateur, tapez la commande show spanning-tree detail.

CommA

CommA#show spanning-tree detailVLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 0009.7C97.41D7
Configured hello time 2, max age 20, forward delay 15
Current root has priority 32769
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times:  hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0/1) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.1
Designated bridge has priority 32769, address 0009.7C97.41D7
Designated port id is 128.1, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 4 (FastEthernet0/4) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.4
Designated bridge has priority 32769, address 0009.7C97.41D7
Designated port id is 128.4, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 7 (FastEthernet0/7) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.7
Designated bridge has priority 32769, address 0009.7C97.41D7
Designated port id is 128.7, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
CommA#

 

CommB

CommB#show spanning-tree detailVLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 000B.BEAB.EE7D
Configured hello time 2, max age 20, forward delay 15
Current root has priority 32769
Root port is 1 (FastEthernet0/1), cost of root path is 19
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times:  hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0/1) of VLAN0001 is root forwarding
Port path cost 19, Port priority 128, Port Identifier 128.1
Designated root has priority 128, address 0001.C928.8B01
Designated bridge has priority 32769, address 0009.7C97.41D7
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 4 (FastEthernet0/4) of VLAN0001 is alternate blocking
Port path cost 19, Port priority 128, Port Identifier 128.4
Designated root has priority 128, address 0001.C928.8B01
Designated bridge has priority 32769, address 0009.7C97.41D7
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 8 (FastEthernet0/8) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.8
Designated root has priority 128, address 0001.C928.8B01
Designated bridge has priority 32769, address 0009.7C97.41D7
Designated port id is 128.8, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
CommB#

 

b. Examinez les données du port Fa0/1. Les résultats affichent l’interface, le rôle et l’état de chaque commutateur. Ils présentent également les informations concernant l’activité et les caractéristiques des ports.

Comment les informations suivantes permettent-elles de vérifier l’état du réseau et de résoudre les éventuels problèmes ?

1) Nombre de transitions vers l’état de transmission : Cela permet de voir si le port est bien fonctionnel. Si la topologie est claire et que les switchs l’ont bien comprise, le nombre d’état vers le forwarding est minimal.

2) Nombre d’unités BPDU reçues et envoyées : Plus le nombre de BPDU est important, plus la topologie du réseau est complexe. Toutefois, si de nombreuses unités BPDU sont reçue et envoyé, cela signifie que l’état des connexions change régulièrement. Les unités BPDU permettant de calculter la nouvelle arborescence suivie par le SPT, si des changements surviennent régulièrement alors qu’on ne modifie pas la topologie en ajoutant des switchs, cela veut dire qu’un ou plusieurs lien sont défectueux, qu’une perte de connexion a eu lieu ou qu’une boucle a été créée.

 

c. Sur chaque commutateur, entrez les commandes suivantes. Définissez le type d’informations apporté par chaque commande :

show spanning-tree summary

CommA

CommA#show spanning-tree summary
Switch is in pvst mode
Root bridge for: default
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is disabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is shortName                   Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001                     0         0        0          3          3

———————- ——– ——— ——– ———- ———-
1 vlans                      0         0        0          3          3

CommA#

 

CommB

CommB#show spanning-tree summary
Switch is in pvst mode
Root bridge for:
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is disabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is shortName                   Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001                     1         0        0          2          3

———————- ——– ——— ——– ———- ———-
1 vlans                      1         0        0          2          3

CommB#

 

 

Étape 8 : Remarques générales

L’équipe chargée de la gestion du réseau décide si le protocole Spanning Tree doit être désactivé sur les commutateurs du réseau de l’entreprise. Expliquez ce que vous pensez de cette décision. Quels sont les avantages et les inconvénients de cette désactivation ?

Sans Spanning Tree d’activé sur ces switchs, le réseau ne peut pas être opérationnel car il existe une redondance du lien les reliant. Ainsi, si une trame est envoyée en broadcast à un des ports d’un switch, celui-ci le renverra à tous les autres ports, y compris sur le lien en redondance.

De ce fait, chaque trame envoyée en broadcast sur l’interface 0/1 par exemple lui reviendra via l’interface 0/4 et inversement.

Le réseau se retrouvera congestionné et tous les postes clients recevront eux aussi ces trames de diffusion et leur carte devra les traiter.

L’équipe chargée de la gestion du réseau se retrouvera en face d’une indisponibilité du réseau du fait d’une broadcast storm.

 

Quelles sont les conséquences sur la conception du réseau ?

Il faut modifier la topologie réseau pour ne garder qu’un seul lien actif entre les deux switchs. Il faut véritablement éviter toute boucle réseau. Chaque élément ne doit être relié qu’une et unique fois aux autres.

 

 

Étape 9 : Modification volontaire du pont racine

a) Modifier la valeur de la priorité de pont en la rendant plus faible pour passer en pont racine. Vérifier le résultat.

Etat avant modification de la priorité de pont sur CommB :

CommB#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    32769
Address     0009.7C97.41D7
Cost        19
Port        1(FastEthernet0/1)
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 secBridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     000B.BEAB.EE7D
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/1            Root FWD 19        128.1    P2p
Fa0/4            Altn BLK 19        128.4    P2p
Fa0/8            Desg FWD 19        128.8    P2p

CommB#

 

Etat après modification de la priorité de pont sur CommB :

CommB(config)#spanning-tree vlan 1 root primary
CommB(config)#exit
CommB#
%SYS-5-CONFIG_I: Configured from console by consoleCommB#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    24577
Address     000B.BEAB.EE7D
This bridge is the root
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Bridge ID  Priority    24577  (priority 24576 sys-id-ext 1)
Address     000B.BEAB.EE7D
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/4            Desg LSN 19        128.4    P2p
Fa0/8            Desg FWD 19        128.8    P2p

CommB#

Le commutateur B est bien devenue pont racine.

Nous pouvons vérifier cela en faisant un show spanning-tree sur le Commutateur A :

CommA#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID    Priority    24577
Address     000B.BEAB.EE7D
Cost        19
Port        1(FastEthernet0/1)
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 secBridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
Address     0009.7C97.41D7
Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/7            Desg FWD 19        128.7    P2p
Fa0/1            Root FWD 19        128.1    P2p
Fa0/4            Altn BLK 19        128.4    P2p

CommA#

C’est maintenant le commutateur A qui se voit avec un port en rôle Alternative et en statut BLOCKED.

 

 

Annexe : Running-config

Commutateur A

(Etat final après l’exécution de toutes les étapes du TP)

CommA#show running-config
Building configuration…Current configuration : 1149 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname CommA
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
!
line con 0
password 7 0822455D0A16
login
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
end

CommA#

 

Commutateur B

(Etat final après l’exécution de toutes les étapes du TP)

CommB#show running-config
Building configuration…Current configuration : 1185 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname CommB
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
spanning-tree vlan 1 priority 24576
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
!
line con 0
password 7 0822455D0A16
login
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
end

CommB#

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *